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Installing Auralia

Installation Instructions

Installing Auralia is very simple and will take will take only a couple of min-
utes, Auralia requires 20Mb of free hard disk space.

1.	 Insert the CD‑ROM provided with the package into your computer’s 
CD‑ROM drive.

2.	 A CD icon will appear on your desktop and a window will open in the 
Macintosh Finder showing the contents of the CD. If a window does 
not open then double-click on the CD icon.

3.	 Double-click on the file ‘Install Auralia’. A new window will appear 
and a default install location will be selected which you can change 
with the popup menu. By default Auralia will be installed in the Ap-
plications folder. When you are ready then click the ‘Install’ button to 
complete installation.

We recommend the use of 800x600 video resolution with at least 256 colours 
for maximum picture quality.  Performance may be affected if this is not avail-
able.

Installation Notes

When running for the first time, Auralia will create a folder called ‘Auralia 
Data’ in the ‘Application Support’ folder. On MacOS X this is located in the 
‘Library’ folder and on earlier systems this is inside the System folder. This 
is the default location for Auralia’s databases. For network use this can be 
changed (see Network Installation in this guide).

If, when running Auralia, you get the message that QuickTime is required, 
you may need to install this. QuickTime is part of the Macintosh system and 
can also be downloaded from http://www.apple.com/quicktime. If you do need 
to install QuickTime then make sure that you install any QuickTime Music 
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components.

If you wish to prevent access to the administration menus you will need to 
enable the login system; see the ‘Security’ section of the ‘User Guide’.
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Network Installation

Network Functionality

In an environment where Auralia is installed on many computers (Desktop 
Site License, Lab Pack or multiple Single Licenses required) we recommend 
that you utilise your computer network (if available) to help you track student 
performance.  Auralia fully supports networked record keeping.  This 
means that all of your student results can be stored centrally, reducing your 
administration load and giving students far greater flexibility regarding the 
choice of computer that they use.

All user, class, statistic and test databases can be stored centrally.

Network Installation Instructions

The network installation process consists of installing Auralia on a central 
network computer (called the ‘server’) and running it. This automatically 
creates databases on the server that can then be made available to all the other 
networked computers (called the ‘clients’). Once Auralia is installed on each 
client, it can easily be setup to read the shared databases from server.

Auralia should be installed on each computer on your network. Although it is 
possible to simply install Auralia onto the server and run it on each of the 
clients, the program will run much more slowly and network traffic may 
be too high to allow correct record keeping.

Server Installation

Installing Auralia on the server is the same as for any other computer. This is 
described in the section ‘Installing Auralia’ at the beginning of this manual.

When Auralia is first run on the server, it will create a folder called ‘Auralia 
Data’ in the ‘Application Support’ folder. On MacOS X this is located in 
the ‘Library’ folder and on earlier systems this is inside the System folder. 
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Databases will also be created in this folder during the first time the program 
is run.

The process of making theses databases available to client computers is by 
using the Macintosh’s built-in file sharing.

Note that in MacOS 9 and MacOS X, personal file sharing only allows 10 
users to connect at any one time. If you wish to have more simultaneous 
users then you will need to run dedicated server software eg. MacOS X 
Server or AppleShare.

This process of sharing files varies depending on the version of MacOS being 
run on the server. The following assumes that you have the network settings 
correctly configured for your network (eg. ethernet, airport) and that Appletalk 
is running.

The server is running MacOS 9:

Under MacOS 9 you can create a new set of databases anywhere on the server 
to be shared. Just open ‘Administration -> Data -> Network’ and select a 
folder where you would like databases to be created.

1.	 Open the File Sharing control panel.

2.	 Select the Start/Stop tab at the top of the window.

3.	 Click on the Start button to start file sharing (not the Program Linking 
button). You may get the message that AppleTalk needs to be switched 
on. This can be configured with the AppleTalk control Panel.

4.	 Select the Users & Groups tab at the top of the window.

5.	 Click on the New User button, which opens a new user window.

6.	 Enter a name in the ‘Identity’ box and a password in the ‘Password’ 
box. e.g. Identity: Auralia User  Password: AuraPasswd

7.	 Close this window and close the File Sharing control Panel.

8.	 Open the ‘Application Support’ folder (or wherever your Auralia 
database folder is located) and click on the Auralia Data folder so that 
it is highlighted.

9.	 Choose Get Info -> Sharing from the File menu.

10.	 Click on “Share this item and its contents” so that it is checked.
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11.	 Click on the popup menu next to User/Group and select your new 
user (e.g. Auralia User)

12.	 Click on the popup menu to the right of this menu and select Read & 
Write.

13.	 Close this window. The folder Auralia Data is now being shared.

The server is running MacOS X:

Under MacOS X, only items in a user’s ‘Public’ folder can be shared. You 
have the option to either create a new set of databases in your ‘Public’ folder 
or move your existing databases:

To create a new set of databases:

1.	 Run Auralia and open ‘Administration -> Data -> Network’

2.	 Click on the ‘Change’ button and navigate to your Public folder.

3.	 Click on ‘New Folder’ to create a new folder in your Public folder. 
Give the new folder a name (eg. ‘Auralia Shared Data’) and click 
Create.

4.	 Select the newly created folder (‘Auralia Shared Data’) and click 
Choose.

5.	 Click on OK to close the Network window.

To move your existing databases:

1.	 Using the Finder, move the ‘Auralia Data’ folder from the 
‘Application Support’ folder (inside the ‘Library’ folder) to your 
‘Public’ folder.

2.	 Run Auralia and open ‘Administration -> Data -> Network’

3.	 Click on the ‘Change’ button and navigate to the folder ‘Auralia Data’ 
in your ‘Public Folder’ and click the Choose button.

4.	 Click on OK to close the Network window.

To share your databases on the network:

1.	 Open the System Preferences from the Apple menu.

2.	 Click on the Sharing icon to bring up the Sharing window.
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3.	 Under the list of services, enable Personal File Sharing and click the 
Start button (if File sharing is off).

4.	 Quit System Preferences. All items in your Public folder are now 
being shared.

We are now going to add you to the user database that resides on the 
server. On the server where you installed Auralia, run the program.  Select 
‘Administration -> Users -> Maintenance’ from the main menu. 
1.	 Click on the button ‘New’; 
2.	 Enter a login name 
3.	 Enter a password 
4.	 Select the Default Class 
5.	 Choose ‘Administrator’ access 
 
Click on ‘Accept’ and then ‘Done’ to exit the screen.  You now have an 
‘Administrator’ user in the databases.  This will ensure that you cannot be 
locked out of Auralia when the security features are enabled.

File Security

Since students need read and write access to the shared databases, there is 
the possibility that the students could delete or corrupt the database files. The 
way to prevent this is to make the database files hidden. This can be done 
from within Auralia with the ‘Administration -> Data -> Network’ window. 
Click on the ‘Hide Files’ button to make them hidden. Although the files are 
not visible in the Macintosh Finder, they are still there and should function as 
normal. To make the files visible again, click on the ‘Show Files’ button.

Workstation Installation

Auralia must be installed on each workstation; Auralia should not be run from 
the server installation.

Installing Auralia on a client is the same as for any other computer. This is 
described in the section ‘Installing Auralia’ at the beginning of this manual.

Each workstation now needs its Auralia configuration changed to allow 
network database access.  Ensure that you have added an administrator 
user to the network database as described in ‘Server Installation’
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1.	 The first task is to mount the shared folder ‘Auralia Data’ on the 
workstation’s desktop. Under MacOS 9 and earlier open the Chooser 
(from the Apple menu) and click on the AppleShare icon. Under 
MacOS X select ‘Connect to Server’ from the ‘Go’ menu. Select the 
server from the available list of computers and click OK. You will be 
shown a list of volumes to mount. 
 
If the server is running MacOS 9 (not the workstation) then you 
should see a folder ‘Auralia Data’. Give the login name and 
Password as setup on the server (e.g.. login: Auralia User, password: 
AuraPasswd) and click OK. The volume Auralia Data should be 
mounted on the desktop of the workstation. 
 
If the server is running MacOS X (not the workstation) then you will 
just see a list of names of server accounts, one of which will be the 
user in whose Public folder are the Auralia databases. You can login 
as a guest. The Public folder containing the Auralia databases will be 
mounted on the desktop of the workstation.

2.	 The next task is to setup Auralia to use the databases on the server, 
instead of the local machine. 
 
Start Auralia and select ‘Administration -> Data -> Network’.  Using 
the ‘change’ button, choose the path of your shared ‘Auralia Data’ 
directory.  This directory was setup as described in the ‘Server 
Installation’ section.

	 Click on ‘OK’ to save your settings and exit the network screen.

3.	 Select ‘Administration -> General -> Security’ from the main menu.  
Check the box labelled ‘Use names and passwords at all times’.  
If you did not add an administrator user correctly in the ‘Server 
Installation’ section, Auralia will not allow you to select this option. 
This is to prevent the enabling of the login system without having an 
administrator defined, a situation that will leave you locked out of the 
administration features.  You will also need to type an administrator 
password in the field provided. This is in case Auralia can not find 
the shared databases (eg. when the server is down). In this case you 
will need to enter this password to access Administration menu items. 
Click on ‘OK’ to exit the Security screen.

4.	 Select ‘Administration -> Users -> Options’ from the main menu. 
‘Automatic User Registration’ and ‘Allow users to change their 
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settings’ should be checked for minimum maintenance.  For a 
complete guide on these settings refer to the section entitled ‘User 
Administration Options’ in the User Guide.  ‘Record Statistics’ should 
also be checked for maximum benefit in a network environment.  This 
will ensure that all results are recorded.
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Technical Support

Before contacting Rising Software Technical Support, please consult this 
User’s Guide and the online help.  If you still cannot resolve your problem or 
query, please contact Rising Software Technical Support through one of the 
methods below.

When contacting Rising Software, please have the following details on hand:

1.	 The version of Auralia you are using;

2.	 The version of Mac OS you are using;

3.	 The type of sound or MIDI equipment you are using, and details of 
your Auralia sound configuration, if it is a sound related problem;

4.	 Whether Auralia is installed on a network, and if so, what type;

5.	 What the exact problem is, such as the exact message given by 
Auralia , what you were doing when the error occurred (eg practising 
intervals, reviewing students’ statistics, etc), and any other details you 
feel are relevant.

Internet

Rising Software maintains a web site at the following address: 
 
 http://www.risingsoftware.com.   
 
Consult our site before using alternative forms of communication.  Listing of 
known bugs and program updates will be listed there.

 Email

We can be contacted through email on the internet (and associated networks) 
at the address: support@risingsoftware.com.
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 Fax

You are welcome to fax any correspondence regarding Auralia to us on +61 
3 9481 3380.  Please include a fax number if you wish your query to be 
responded to by fax. 

 Telephone

You can reach the Rising Software office during business hours on + 61 3 
9481 3320.  If you are in the USA, please call (888) 667 7839.  If we are 
unavailable, please leave a message and we will return your call.

 Post

You can reach Rising Software by post at:

Rising Software Australia
3 Darling St
Fairfield, VIC  3078
AUSTRALIA



Auralia 2.1 Installation Guide    15

License Agreement

WARNING

PERMISSION TO USE THIS SOFTWARE IS CONDITIONAL UPON YOU AGREEING TO 
THE TERMS SET OUT BELOW. BY DOWNLOADING, INSTALLING OR USING ANY 
COMPONENT OF THE SOFTWARE, OR BY REGISTERING THE PRODUCT, YOU (AS 
AN INDIVIDUAL OR LEGAL ENTITY) AND YOUR EMPLOYEES (IF ANY) AGREE TO 
BE BOUND BY THE TERMS OF THIS AGREEMENT WHICH WILL GOVERN THE USE 
OF THE PRODUCT.  

IF YOU DO NOT ACCEPT THESE TERMS, DO NOT DOWNLOAD, INSTALL OR 
OTHERWISE USE ANY COMPONENT OF THE SOFTWARE.

IF YOU DO NOT ACCEPT THESE TERMS AND THE SOFTWARE HAS BEEN SUPPLIED 
IN A SEALED PACKAGE, PROVIDED THAT YOU DO NOT OPEN THE SEALED 
PACKAGE YOU MAY, WITHIN 14 DAYS OF PURCHASE, RETURN THE SOFTWARE 
IN ITS INTACT SEALED PACKAGE TO YOUR SUPPLIER TOGETHER WITH DATED 
PROOF OF PURCHASE FOR A FULL REFUND.

The Product is copyright © Rising Software Australia Proprietary Limited and its licensors 
1996 - 2008.

1. Definitions

In this Agreement the following words and expressions have the following meanings:

“Demonstration Software”:	 components of the Software, containing some but not all 
of the components of the Software which is supplied for evaluation purposes only and is not 
suitable for commercial or education use.

“Documentation”: the Auralia User Guide, Auralia Install Guide, on-screen help and any other 
documentation relating to the Software supplied to you in any form by the Licensor or with the 
Software.

“Firebird Software”: means open source software produced by the FirebirdSQL Foundation 
(Inc.).

“Intellectual Property Rights”: all and any patents, patent applications, trade marks, service 
marks, trade names, domain names, registered designs, unregistered design rights, copyrights, 
know how, trade secrets and rights in confidential information, URLs and all and any other 
intellectual property rights, whether registered or unregistered, and including all applications 
and rights to apply for any of the same.

“Interbase Public Licence”: the interbase public licence for Firebird software that is available 
at http://www.firebirdsql.org/index.php?op=doc&id=ipl.

 “Licensor”: Rising Software Australia Proprietary Limited, an Australian company (A.C.N. 
057 077 213) of 3 Darling St, Fairfield, Victoria, 3078, AUSTRALIA.
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“Software”: Auralia for Macintosh, installers, demonstrations of other software, and any 
other programs or files supplied to you on or with the Auralia CD-ROM or download and all 
modifications, enhancements, updates or upgrades to the Software but does not include any 
Firebird Software.

“Product”: the Software and the Documentation.

“Single Copy”: a Product provided for use on a single computer terminal

“Single Professional”: a Product provided for use on a single computer terminal.

“Single Academic”: a Product provided for use on a single computer terminal.

“Student Edition”: a Product provided for use on a single computer terminal.

“Multi User License”: a Product provided for use on multiple computers.

“Site License”: a Product provided for use on multiple computers.

“Lab Pack”: a Product provided for use on five (5) computer terminals

2. License

 2.1	 (1) Subject to clause 2.1(2) and clause 2.8 the Licensor grants to you a non-
exclusive non-transferable license to use the Software in accordance with the Documentation.

(2) If you have requested Demonstration Software, the Software licensed under this Agreement 
is limited to the Demonstration Software and the Licensor expressly disclaims any warranty 
that the Demonstration Software is of merchantable quality or fit for any purpose and will 
not be liable for any damage or loss whatsoever as a result of your use or reliance on the 
Demonstration Software. 

(3) If the Product is a Site License or a Multi User License, you may install the software on the 
licensed number of computer terminals. Any further use if prohibited

(4) If the Product is a Lab Pack, you may install the software on up to five (5) computers, on a 
single geographical site.

(5) If the Product is not a Lab Pack, Multi User License or Site License, you may install the 
Software on a single computer.

(6) Title to the Product is not transferred to you.  Ownership of the Product remains vested in 
the Licensor.  All other rights are reserved.

2.2	 You may make one printout for your own use of any part of the Documentation 
provided in electronic form.  You shall not make or permit any third party to make any further 
copies of any part of the Product whether in eye or machine-readable form.

2.3	 You must not, and must not cause or permit any third party to, translate, enhance, 
modify, alter, adapt or create derivative works based on the Product or any part of it for any 
purpose (including without limitation for the purpose of error correction), or cause the whole 
or any part of the Product to be combined with or incorporated into any other program, file or 



Auralia 2.1 Installation Guide    17

product for any purpose, except as expressly permitted by the Documentation or otherwise in 
writing by the Licensor..

2.4	 You must not, and must not cause or permit any third party to, decompile, decode, 
disassemble or reverse engineer the Software in whole or in part for any purpose.

2.5	 You must not, and must not cause any third party to translate, convert, decode or 
reverse engineer the database files in any version, or modify any such file (except by using the 
Software in accordance with the Documentation), in whole or in part for any purpose.

2.6	 The Product or any part of it must not be used to infringe any intellectual property 
right or right of privacy, publicity or personality or any other right whatsoever of any other 
person or entity.

2.7	 Use of the Firebird Software that is provided with the Software is subject to the 
terms and conditions of the  Interbase Public Licence.

2.8	 You acknowledge and agree that: 

(1) you have read, understood and agree to be bound by the terms of the Interbase Public 
Licence;

(2) you are responsible for ensuring that any employees who have access to the Software are 
aware of the conditions of the Interbase Public Licence.

3. Intellectual Property 

3.1	 You acknowledge and agree that all Intellectual Property Rights, including 
without limitation the copyright  in the Product as a whole and in the components of the 
Product as between you and the Licensor belongs to the Licensor and is protected by law.  
Further details of the ownership of all copyright in the components of the Product are set out in 
the Product.

3.2	 You must not attempt to assert any intellectual property rights over the Product.  
You must not remove or alter any logo, copyright or other proprietary notices, symbols or 
labels in the Product.

4. Liability of the Licensor

4.1	 You acknowledge that in entering into this Agreement you have not relied in any 
way on our representations, descriptions, illustrations, specifications, skill or judgment and that 
you have satisfied yourself as to the condition and suitability of the Software for your purposes.

4.2	 The Licensor does not warrant that the functions contained in the Software will 
meet your requirements or is suitable for your use or any other purpose or that operation of the 
Software will be uninterrupted or problem or error free. The Licensor does not warrant that 
the Software will function as documented, expected or promised or is of merchantable quality. 
Use of the Software or any part of it is at your sole risk.  You must determine that the Software 
meets your requirements, including compatibility with other computer programs or equipment. 

 4.3	 Unless this Agreement expressly provides otherwise, the Licensor gives no 
condition, warranty, undertaking or representation in relation to the condition, accuracy, 
suitability, quality of or title to the Software and to the extent permitted by law, all implied 
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conditions, warranties and liabilities (including liability as to negligence) in relation to same 
arenegated and excluded. 

4.4	 Notwithstanding clause 4.2, the Licensor does warrant that the physical medium 
upon which the Software is provided and the Documentation will be free from defects in 
materials and workmanship for a period of fourteen (14) days after the date of original 
purchase (the “Warranty Period”).  If a defect in the physical medium or Documentation shall 
occur during the Warranty Period, the Product may be returned with dated proof of purchase 
to the Licensor who will at its sole discretion either return the price paid or repair or replace it 
free of charge.

4.5	 You will indemnify the Licensor and keep the Licensor indemnified against:

(1) all and any demands, claims, actions and proceedings whatsoever and howsoever arising 
made by any third person in connection with or arising out of your use of the Software (except 
to the extent that they arise due to the fault of the Licensor or its employees or agents); and

(2) all and any losses, costs, expenses and damages whatsoever and howsoever incurred by 
the Licensor in connection with or arising out of a breach by you of any provision of this 
Agreement.

4.6	 Nothing in this Agreement excludes, restricts or modifies any condition, warranty, 
right or remedy which is conferred on you by the Trade Practices Act 1974 (Cth) or any other 
consumer legislation as amended (the “Acts”) which we are not lawfully able to exclude, 
restrict or modify.  Where we breach a non-excludable condition or warranty which has been 
implied by the Acts, our liability for breach will be limited, to the extent lawfully permissible, 
to:

(1) in the case of supply of goods, the replacement of the goods or the supply of equivalent 
goods, the repair of the goods, the payment of the cost of replacing the goods or of acquiring 
equivalent goods, or the payment of the cost of having the goods repaired;

(2) in the case of the provision of services, the supplying of the services again, or the payment 
of the cost of having the services supplied again;

whichever the Licensor sees fit to provide.

4.7	 Notwithstanding anything to the contrary in this Agreement, the Licensor’s entire 
liability for breach of its covenants and warranties in this Agreement and for any defect or 
errors in the Product shall  be limited to the price paid by you for the Product.

4.8	 To the extent permitted by law, you acknowledge and agree that the Licensor 
is not liable for any loss or damage, including any special, indirect or consequential loss or 
damage (including economic loss, loss of profits, business interruption, loss of business OR 
loss of revenue) whether such loss is caused by the Licensor’s breach of its obligations under 
this Agreement or any negligence or other tortious act or omission or  in any way results from 
your use, non-use or inability to use the whole or any part of the Product (including as a result 
of any malfunction, breakdown, error or virus in the Software) or otherwise OCCURS in 
connection with this Agreement.

5. Termination

	 This License shall terminate automatically upon your destruction or if you 
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otherwise lose custody of the Product.  In addition, the Licensor may elect to terminate this 
License in the event of a material breach by you of any condition of this Agreement or any of 
your representations, warranties, covenants or obligations hereunder.  Upon notification of such 
termination by the Licensor you will immediately delete all copies of the Software from your 
computer(s), destroy any other copies of the Product or any part thereof, or return the Product 
to the Licensor.

6. Miscellaneous

6.1	 No failure to exercise and no delay in exercising on the part of the Licensor 
of any right, power or privilege arising hereunder shall operate as a waiver thereof, nor 
shall any single or partial exercise of any right, power or privilege preclude any other or 
further exercise thereof or the exercise of any other right, power or provilege.  The rights 
and remedies of the Licensor in connection herewith are not exclusive of any rights or 
remedies provided by law.

6.2	 You may not distribute, loan, sub-license, rent, assign, lease (including 
without limitation renting or leasing a computer on which the Product is installed) or 
otherwise transfer the Product to any third party without the Licensor’s prior written 
consent, which the Licensor may grant, condition or withhold in the Licensor’s sole 
discretion.

6.3	 You agree to the collection and use of your personal data in accordance with 
the Licensor’s privacy statement (available from the Licensor or at the Licensor’s website 
at http://www.risingsoftware.com/privacy.shtml) which may change from time to time.

6.4	 This Agreement is intended by the parties hereto to be a final expression of 
their agreement with respect to the subject matter hereof and a complete and exclusive 
statement of the terms of such agreement.  This Agreement supersedes any and all prior 
understandings, whether written or oral, between you and the Licensor relating to the 
subject matter hereof.

6.5	 This Agreement shall be construed and governed by the laws of Victoria, 
Australia and both parties agree to submit to the exclusive jurisdiction of the Victorian 
courts.

6.6	 The provisions of this Agreement shall not be varied, except by agreement in 
writing and signed by the parties.

6.7	 If there is a disagreement between you and the Licensor that cannot be 
resolved then prior to commencing proceedings in any Court, you must refer the matter 
to the Australian Commercial Disputes Centre for arbitration in accordance with the 
Centre Guidelines on Arbitration.  The decision of the arbitrator (including any award as 
to costs) will be final and binding.


